HTTPCSEuropean cybersecurity leader

| About us
09/07/2012 :

phpList 'status' Cross Site Scripting security breach


HTTPCS Advisory : Httpcs-24
Product : phpList
Version : 2.10.18
Date : 09/07/2012
Severity level: ○ Less Critical
Description : A vulnerability has been discovered in phpList, which can be exploited by malicious people to conduct cross-site scripting attacks. Input passed via the 'status' parameter to '/lists/admin/?page=send&id=1&tab=Misc' is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.
Page : /lists/admin/?page=send&id=1&tab=Misc
Variables : workaround_fck_bug=1&sendtest=Send Test Message&save=Save Message as Draft&id=1&expand=0&status=[VulnHTTPCS]
Type : XSS
Method : POST
Solution : The vulnerability has been fixed in version 2.10.19
Credit : HTTPCS [Web Vulnerability Scanner]


HTTPCS desktop screenshot Scanner HTTPCS tablet screenshot Scanner HTTPCS phone screenshot Scanner