HTTPCSEuropean cybersecurity leader

| About us
20/09/2012 :

AShop 'language' Cross Site Scripting Vulnerability


HTTPCS Advisory : Httpcs-104
Product : AShop
Version : 5.3.4
Date : 17/09/2012
Severity level: ○ Less Critical
Description : A vulnerability has been discovered in AShop, which can be exploited by malicious people to conduct cross-site scripting attacks. Input passed via the 'language' parameter to '/language.php' is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.
Page : /language.php
Variables : language=[VulnHTTPCS]
Type : XSS
Method : GET
Solution : The vulnerability has been fixed in version 5.3.5 <a target="blank" href="http://www.ashopsoftware.com/update/release-notes.html">http://www.ashopsoftware.com/update/release-notes.html</a>
Credit : HTTPCS [Web Vulnerability Scanner]


HTTPCS desktop screenshot Scanner HTTPCS tablet screenshot Scanner HTTPCS phone screenshot Scanner